Loading...
 
Galaxia Workflow Engine

Galaxia Workflow Engine


fixed: non-interactive activities and the amp bug

United States

Ok, I've committed to 1.8 branch, and to the 1.9 branch. The long time bug with the & amp vs. & should now be fixed.

If people are still seeing the problem with routing and/or non-interactive activities being skipped, please let me know.

.josh ("burley" on IRC, #tikiwiki)

France

Hi,

I download Tikiwiki this week, so I think I have a recent version of Galaxia. I have already the problem. Effectively, there's not more amp in config.php, but the problem is still there. I found an other amp in config.tikiwiki.php and even if I correct that, I have the problem with non-interactive activities.

Do you have an other idea ?

Ashuap


THIS IS NOT FIXED. (At least not in 1.8.5)

The "amp" has been removed, however, the semicolon ; has been left in.

In config.php, you need to go to the 'galaxia_execute_activity' function defintion at the bottom. Look for this line:

Image
$parts[count($parts)-1] = "tiki-g-run_activity.php?activityId=$activityId&;iid=$iid&auto=$auto";


You have to remove the semicolon right after "$activityId&".

Frankly, I'm somewhat stunned that a bug that completely breaks automatic activity processing has been left unfixed in the "stable" build for so long. I mean, not even the trivial example in the manual works because of this!

Brazil

If your main interest in TiwiWiki is Galaxia (mine is), use 1.9.0. It has several bugfixes and improvements. The particular issue you mention is already fixed in 1.9.0. The other bugs that I and others discussed in this message board are also based on 1.9.0. Regards,

Georger

> THIS IS NOT FIXED. (At least not in 1.8.5)
>
> The "amp" has been removed, however, the semicolon ; has been left in.
>
> In config.php, you need to go to the 'galaxia_execute_activity' function defintion at the bottom. Look for this line:
>

> Image
$parts[count($parts)-1] = "tiki-g-run_activity.php?activityId=$activityId&;iid=$iid&auto=$auto";

>
> You have to remove the semicolon right after "$activityId&".
>
> Frankly, I'm somewhat stunned that a bug that completely breaks automatic activity processing has been left unfixed in the "stable" build for so long. I mean, not even the trivial example in the manual works because of this!