Loading...
 
Architecture / Installation

Architecture / Installation


undrecognized smarty tag

posts: 6

New install then after trying to dispay logo I get this error and nothing else after log-in.

I was only able to see this error after adding the error handling functions in the smarty class files.


Fatal error: Smarty error: in evaluated template line 1: syntax error: unrecognized tag 'img' (Smarty_Compiler.class.php, line 580) in E:\htdocs\IjusWiki\lib\smarty\libs\Smarty.class.php on line 1091


posts: 6

> New install then after trying to dispay logo I get this error and nothing else after log-in.
>
> I was only able to see this error after adding the error handling functions in the smarty class files.
>
>
> Fatal error: Smarty error: in evaluated template line 1: syntax error: unrecognized tag 'img' (Smarty_Compiler.class.php, line 580) in E:\htdocs\IjusWiki\lib\smarty\libs\Smarty.class.php on line 1091
>
>

Thnks for the info, that may be exactly what is happening, the only problem I have now is being able to make the changes. After I login all I get is the error. How can I find get to a place where the changes can be made. Does the literal need to be added to a template? does it need to be added to a value in the database? I have a blank screen with the error that's it.

posts: 4644 Japan

> > New install then after trying to dispay logo I get this error and nothing else after log-in.
> >
> > I was only able to see this error after adding the error handling functions in the smarty class files.
> >
> >
> > Fatal error: Smarty error: in evaluated template line 1: syntax error: unrecognized tag 'img' (Smarty_Compiler.class.php, line 580) in E:\htdocs\IjusWiki\lib\smarty\libs\Smarty.class.php on line 1091
> >
> >
>
> Thnks for the info, that may be exactly what is happening, the only problem I have now is being able to make the changes. After I login all I get is the error. How can I find get to a place where the changes can be made. Does the literal need to be added to a template? does it need to be added to a value in the database? I have a blank screen with the error that's it.

Did you edit the template to add the img tag? Or are you using the Site Identity feature to display the image? If you can replace the relevant template with a copy that doesn't have the tag, FTPing it to the server, that'll at least give you access to the site again. If the image problem stems from something added via Site Identity, then I guess that has to be deactivated first. You could go to your database with phpMyAdmin, to the tiki_preferences table, and look for and delete something like feature_site_identity.

Once you have access again, you can take care of the image problem. Normal HTML image syntax can be used in Smarty templates.

-- Gary - themes.tw.o

posts: 6

> > > New install then after trying to dispay logo I get this error and nothing else after log-in.
> > >
> > > I was only able to see this error after adding the error handling functions in the smarty class files.
> > >
> > >
> > > Fatal error: Smarty error: in evaluated template line 1: syntax error: unrecognized tag 'img' (Smarty_Compiler.class.php, line 580) in E:\htdocs\IjusWiki\lib\smarty\libs\Smarty.class.php on line 1091
> > >
> > >
> >
> > Thnks for the info, that may be exactly what is happening, the only problem I have now is being able to make the changes. After I login all I get is the error. How can I find get to a place where the changes can be made. Does the literal need to be added to a template? does it need to be added to a value in the database? I have a blank screen with the error that's it.
>
> Did you edit the template to add the img tag? Or are you using the Site Identity feature to display the image? If you can replace the relevant template with a copy that doesn't have the tag, FTPing it to the server, that'll at least give you access to the site again. If the image problem stems from something added via Site Identity, then I guess that has to be deactivated first. You could go to your database with phpMyAdmin, to the tiki_preferences table, and look for and delete something like feature_site_identity.
>
> Once you have access again, you can take care of the image problem. Normal HTML image syntax can be used in Smarty templates.
>
> — Gary - themes.tw.o

This is some more great info; at least now I have a some directions to pursue, thanks I really appreciate the help.

posts: 9

Hi guys, I just experienced the very same error, trying to create a module with images.

1. I had disabled Admin>>General "all modules displayed to all users" so the module i was testing displayed only to admins - bad idea as we both found out. In the future i will test with some other group. :-)

> > New install then after trying to dispay logo I get this error and nothing else after log-in.


> > Fatal error: Smarty error: in evaluated template line 1: syntax error: unrecognized tag 'img' (Smarty_Compiler.class.php, line 580) in E:\htdocs\IjusWiki\lib\smarty\libs\Smarty.class.php on line 1091


2. So we resolved this by tweaking the database directly from the domain admin (cpanel)

Select mysqldatabases

Select phpmyadmin

Wait for the long list of tables to load.

Select tiki_user_modules

In tiki_user_modules the “parse??? field was “null???, changing this to a lowercase “y??? resolved the problem. The images in the module did not diplay mind you, but the error was gone.

In my ignorance of all most things programming I would probably call this a bug - null is probably the wrong default value, especially when you have a wysiwyg editor (which is very nice) inviting people to drop wiki-syntax img tags into the module.

MLP

posts: 6

> Hi guys, I just experienced the very same error, trying to create a module with images.
>
> 1. I had disabled Admin>>General "all modules displayed to all users" so the module i was testing displayed only to admins - bad idea as we both found out. In the future i will test with some other group. :-)
>
> > > New install then after trying to dispay logo I get this error and nothing else after log-in.
>
>
> > > Fatal error: Smarty error: in evaluated template line 1: syntax error: unrecognized tag 'img' (Smarty_Compiler.class.php, line 580) in E:\htdocs\IjusWiki\lib\smarty\libs\Smarty.class.php on line 1091
>
>
> 2. So we resolved this by tweaking the database directly from the domain admin (cpanel)
>
> Select mysqldatabases
>
> Select phpmyadmin
>
> Wait for the long list of tables to load.
>
> Select tiki_user_modules
>
> In tiki_user_modules the “parse??? field was “null???, changing this to a lowercase “y??? resolved the problem. The images in the module did not diplay mind you, but the error was gone.
>
> In my ignorance of all most things programming I would probably call this a bug - null is probably the wrong default value, especially when you have a wysiwyg editor (which is very nice) inviting people to drop wiki-syntax img tags into the module.
>
> MLP
>
> Thanks for the input, it makes sense. I won't have the chance to get to this for a few days but I'll let you know if it solved my problem when I do