Loading...
 
Architecture / Installation

Architecture / Installation


No login possible anymore after upgrade 1.9.7 to 2.4

posts: 19 Germany

Hi there,

I followed the upgrade instructions at http://doc.tikiwiki.org/tiki-index.php?page=Upgrade+1.9.x+to+2.x&bl=y

To upgrade my Tiki site.
The database upgrade scripts worked fine (both of them), so I locked the install script and tried to enter Tiki.

However, the login is not working anymore! Neither as a normal user nor as admin. After clicking on "login", I simply return to the main screen, but I am not

Any ideas what I can do to be able to login again?

Right now, my site is a "read only site"...

posts: 52 Brazil

Hey, recently I've updated a Tiki farm from 1.9.11 to 2.4 without problems. I'm not sure but I think that on my tests I've experienced the same problem and the solution was to clean the template cache. You can do this by removing the files under the templates_c directory except the index.php.

Other thing I had to do was run the script to convert the preferences variable to the new format against all my template files.

Let me know if none of the two ideas above solve your problem.

posts: 19 Germany

Hi rodrigo,

I emptied the templates_c directory (there was no index.php in there), but that did not help.

Which update script are you referring to? Where can I find it?

Thanks


posts: 52 Brazil

Hey, you can find the script in the SVN repository in the following location:

https://tikiwiki.svn.sourceforge.net/svnroot/tikiwiki/branches/2.0/doc/devtools/convert_templates_prefs-2.0.php

I'm not sure if there is a better approach to the problem. To check if your problem is related with the change in the way preferences are accessed in the templates you can change your site style directly in the database and see if your site works with the Tiki default style.


Upcoming Events

No records to display

Menu