Loading...
 
Features / Usability

Features / Usability


Registration email validation missing link

posts: 16
tiki login
Users can register yes yes yesyes
Validate by email yes
validate user's email server yes
Require validation by Admin yes
results===> worked failed failedworked
note===> errant theme admin's email validation link logins with new registered username. Errant theme & menu 43. Who's there (online users) shows admin and new registered user both online. This is incorrect. same as other failederrant theme
note===> admin under new reg. username logs out, logs back in under admin, new registered user is still showing in Who's there. same as other failed
note===> Admin Users shows new registered user Never logged in. same as other failedfails to validate hotmail account


In the above table I listed the 4 different login settings, 2 worked and 2 failed. I have struggled with validation registrations and do not think it is with my php.ini settings. It may be a corrupt file somewhere but I do not want to go there yet. I have removed any Tracker from registration. Double checked @mail functions and the only failure I get is when registration attempt to validate. I have also listed some wackiness when admin validates from email validation notices. I am sure tiki is doing exactly what I am telling it to do. What could I be telling it to do that would block registration validations from being sent? The missing piece is newly registered user receiving a validation email after admin login via admin validation email notice with valiation url for user...wachiness follows after admin validates. Also, on the "fail" accounts, username is in User accounts but login error states account has been disabled.

posts: 1584 Canada

wow!

Excellent research!



posts: 16

TiKi40. And I misspoke on the menu...think it is 42...the Aplication menu. I installed the company_intranet4 profile. Other than that, I am new to tiki and have done very little in the way of customizing it outside of check boxes and perms...a little menu stuff.

The weirdness is like tiki has a multple username issue. I am sure that the login script on the admin-validations-with-new-registered username is a default setup. There is no wiki menu 42 and it assumes the anonymous theme. Tiki does not seem to know that who is logging out also. On the next legitimate login there is either the bogus new username or the admin in the Who's online. I know this is incorrect. Also, the admin under the bogus username can send Contact Us and use all the basic features with the bogus username getting all the credit. That is, I recieve message from the bogus name. But the bogus username and password get an Acount disable message at login and the Admin User states that the bogus user Never logged in...all the while I am get messages from the bogus user.

posts: 16

I was running without PDO support but now have it with PHP 5.2. Still no change in registration email validations. Still geting Account validated successfully followed by Account disabled. Thanks for tips though.

Because I have never ran through the entire, user registers, email validation gets sent to "admin", admin click email link and validates account, account validator sends new user a notification of account standing--at least that is how I see it playing out. Is that how it works? If "Validate by email" is checked in Login Feature, is it automatically checked in Admin Users "Send an email to the user in order to allow him to validate his account"? When the admin clicks the "You or someone registered this email address at www.mytiki.com If you want to be a registered user in this site you will have to use the following link to login for the first time:" link and the tiki site's page opens up, what is that page? Is the admin suppose to do anything other than click that "...login for the first time:" link?


Upcoming Events

No records to display

Menu