Loading...
 
Français

Français


3 petits soucis

posts: 11

Bonjour,

Je développe un site pour mon stage et j'aurai besoin d'un peu d'aide.
Je n'ai que 2-3 petits problèmes et la solution est peut-être évidente, mais je ne la trouve pas.

Mon premier petit problème est dans l'utilisation de "DbReport". J'ai déjà fait mention de celui-ci sur ce topic.
Je crée un lien avec une concaténation, jusque la ça fonctionne. Le lien est correctement créé.
Mon problème : je dois afficher une image avec ce lien, mais elle ne s'affiche pas :/
Voici le code pour vous montrer :

{DBREPORT(db=>stageAP)} SQL "SELECT nom, site, CONCAT('\"http://www.lanup.be/images/partenaires/big/',image,'\"') AS logo, description FROM partenaires" GROUP [nom] "[nom]":h1 TABLE HEADER :even{cursor:pointer;} :odd{cursor:pointer;} CELL :{text-align:left;background-color:white;color:black;} "Site officiel" :i HEADER CELL :{text-align:left;background-color:white;color:black;} "{IMG(src="[logo]")}{IMG}" HEADER CELL :{text-align:left;background-color:white;color:black;} "Description : " "[description]" {DBREPORT}

La question, peut-on afficher des images avec "DbReport"? Vous pouvez voir la page ici


Second petit problème, c'est sur une requête SQL(je débute dans le domaine :p). Je dois faire un "COUNT" sur un champ. Je dois dire par évènement, combien de personne sont inscrites.
J'ai 2 tables, "JoueursInscrit" et "Evenements". Dans "JoueurInscrit", j'ai une clé étrangère qui pointe sur "Evenements".
Actuellement, voici la requête que j'ai :

SQL "SELECT DISTINCT joueurInscrit.nomJoueur, joueurInscrit.evenements_id, evenements.id, evenements.nom, evenements.nbrJoueurMax, evenements.lieu FROM joueurInscrit, evenements WHERE joueurInscrit.evenements_id=evenements.id" GROUP [evenements_id] "[nom]":h1


L'affichage de ces informations est bon, il ne me reste plus que le "COUNT" où je bloque.
Si quelqu'un est doué en requête SQL, peut-il m'aider sur ce point? ^^
Vous pouvez voir le résultat ici.


Dernier petit problème, j'aimerai que la page d'accueil soit la page des articles.
Dans l'administration, je vais dans les préférences générales, puis dans navigation et je choisis comme page d'accueil "Articles".
J'enregistre mes préférences, mais la page d'accueil reste une page Wiki...
Est-ce un bug connu ou je fais une erreur quelque part?

Merci d'avance pour les personnes qui liront ce message et qui tenteront de m'aider :-)

Bonne journée.