Features / Usability

Features / Usability

Catagory Permissions for Approval of Flagged Revisions (tiki_p_wiki_approve)

posts: 72 United States

Is it possible to assign catagory permissions for approval of flagged revisision to a wiki page (tiki_p_wiki_approve) to a group?

I'm using tiki8, and want to assign approval permisions to certain user groups, for certain object catagories.

For example:

Group A and approve Catagory A, but not B or C.
Group B can approve Catagory B, but not A or C.
Group C can approve Catagory C, but not A or B.

I can assign tiki_p_wiki_approve as a global permission, but when I go to catagory permission there is not an option for tiki_p_wiki_approve. It is just not there. Below is the address for these permissions.


If I go to Object Permissions List, and then click on the catagory in the "Reason" column, it takes me to the address below. Similar to the previous address, except the "permType=category". From this page I can view and assign tiki_p_wiki_approve, but it doesn't seem to work.


I have tried assigning tiki_p_wiki_approve globally to all groups and then takeing it away at the catagory level, and also not assigning it globally and assigning it on the catagory level, but neither works. Either all my groups can approve any catagory, or none of them can approve any catagories.

posts: 72 United States

I'm still trying to figure this one out. If anyone has experience and can chime in, help would be appreciated.

I'm trying to assign wiki_approve permission to specific user groups for specific catagories, but it only seems possible on the global level.

Can anyone even confirm that this is an option?

posts: 72 United States

Thanks Marc. I tried, but it did not seem to fix the problem.

I replaced my userslib.php with the revision 40636 you linked to, then restarted my tiki site. Still having the same issues.

Seems to be two issues.

Issue 1

When I go to Admin Catagories, and click on "Edit Parmissions for this catagory" (the little key icon), there is no option for tiki_p_wiki_approve on the "Assign permissions to this category" page. Is is not in the list.

However, if I go to Assign global permissions, and click on "Object Permissions List", then go to the "Reason" column under the "Catagory Permissions" tab and select a catagory, it takes be back to the "Assign permissions to this category"; only this time tiki_p_wiki_approve is visable.

I'm not sure how/why, but the method of navigation I used to get to "Assign permissions to this category" page seem to have an affect on what permissions I can edit.

Issue 2

I can apply tiki_p_wiki_approve globally, and remove it at "Assign permissions to this category", but all assigned Globally still have the permission and can approve.

If I don't assign it Globally, but assign the permission at the category level, the uses still don't have the permission.

Seem like the global permission is all that is applied in either case.

Thanks again for your help. I'm not an experienced coder, but if there is anything I can do to help please with this issue please point me in the right direction.

posts: 1595 Canada

Please clear all cache by visiting: tiki-admin_system.php?do=all

M ;-)

posts: 72 United States

Ahh... such a noob mistake. I should know better; sorry about that.

I cleared all cache and the fix works.

I can now assign catagory permissions for tiki_p_wiki_approve, and the permissions are effective.

Thanks for your help with this. If this goes live I would be happy to update the docs if needed.

Upcoming Events

No records to display