Loading...
 
Themes

Themes


Code Listing using the wrong style

I recently upgraded my Tiki site from 7.2 to 9.1 . Before the upgrade, my code listings all looked like this...

This is some code listing using \{CODE()\} and \{CODE\}


But now they look like this. If you look closely, the listing on the referenced page initially starts out in a fixed-width font (good), but after about 1 second, it changes to a proportional font (bad).

Code listing are supposed to be in fixed-width (non-proportional) fonts. What's going on? and how do I fix it?

If it makes any difference (it shouldn't), I am using the arcturus theme with the amette option set.

Faithfully,
Sean B. Durkin

Canada
CodeMirror is kicking after that second. Can you turn it off and see if it helps?

Where is the switch for CodeMirror in Tiki 9 located?

The doc.tiki page for this appears only to be valid for Tiki 7 and Tiki 8.


Japan

The syntax highlighter (Codemirror) switch is in the same place in Tiki 9 as in the previous versions.

-- Gary


This is the instruction from this page to switch Codemirror:

In Tiki7 and Tiki8, codemirror was not enabled by default in new installations, so that it had to be enabled through: "Admin home > Text area ("Editing and plugins") > General Settings > Syntax Highlighter (CodeMirror)

If you don't see this option, ensure that you have the advanced admin settings displayed (tick the checkbox "advanced" or "experimental" in the admin panels.

Here is a screen-shot from http://lockbox.seanbdurkin.id.au/tiki-admin.php . In this screen-shot, Preference Filters = Basic + Advanced + Experimental.

You will note that under "Text area", there is no menu item for General Settings, the menu items are...

* Cookies
* External Pages Cache
* Toolbars
* DSN
* External Wikis

Please advise. How can I turn CodeMirror off?


Japan

You need to go to the page http://lockbox.seanbdurkin.id.au/tiki-admin.php?page=textarea . This page is linked to from the "Editing and Plugins" icon in the top row of icons, as shown in your screenshot. I think the text links shown at the bottom of the screenshot are meant to be quick-links or supplementary or something but this relationship isn't clear, so this should probably be improved/fixed.

-- Gary


Thanks a bunch Gary! razz


With this advise, I was able to turn off the malfunctioning CodeMirror. It seems the correct path to the CodeMirror switch is ...

Admin home > Editing and Plugins > General Settings > Features > Syntax Highlighter (CodeMirror)


Problem solved.

I took the liberty of correcting the doc.tiki.org page on this feature accordingly.


Faithfully,
Sean B. Durkin