Architecture / Installation

Architecture / Installation

Upgrade Tiki18 to 21 Error

posts: 742 United States

Dear folks, I keep getting this same error with multiple attempts upgrading my tiki18 to 21

Fatal error: Uncaught Error: Call to a member function set_preference() on null in /home/woodwiki/public_html/installer/schema/20180410_install_piwik_plugin_tiki.php:17 Stack trace: #0 /home/woodwiki/public_html/installer/installlib.php(186): upgrade_20180410_install_piwik_plugin_tiki(Object(Installer)) #1 /home/woodwiki/public_html/installer/installlib.php(141): Installer->installPatch('20180410_instal...') #2 /home/woodwiki/public_html/installer/tiki-installer.php(1061): Installer->update() #3 /home/woodwiki/public_html/tiki-install.php(105): include_once('/home/woodwiki/...') #4 {main} thrown in /home/woodwiki/public_html/installer/schema/20180410_install_piwik_plugin_tiki.php on line 17

Can someone please guide me to a solution?

Managed VPS

posts: 8511 Israel

Hello John,

I’ve seen this kind of error two or three times with older tiki being updated several times (from version to version to another version, etc).

This is a PHP error that comes from something that was "accepted" before (while it was not intended) and now with PHP7 (more strict I guess) it is causing an error.

The last case I remember;
A tiki user filling his articles author fields with an email address instead of a user name or a regular text string. It was working before (somehow) but causes the same king of error in an article plugin on its home page after moving to PHP7 (or 7.2 ?).

Try to check what this "piwik_plugin" is used for ?
(can be one of you plugin or the Piwik Admin panel setting - a lot are built around plugins).

If you don’t use it, reset all values to default or delete the plugin.

Let us know ;-)

posts: 742 United States

Bernard thanks completely.
I do use Piwik now Matomo, instead of Google Analytics. I'll start there and try to the process again. You been very helpful, thanks again.

posts: 742 United States
Thanks again Bernard, I completely disabled Piwik and it worked. I renamed the 20180410_install_piwik_plugin_tiki.php file altogether so the software couldn't find it, and I disabled Piwik in my control panel, and it finally worked.