Architecture / Installation

Architecture / Installation

Tiki Wiki - Install Loop 'Security Precaution'

posts: 8503 Israel
Virgo SHAKA wrote:

Hi there!

I'm a new user of Wikis and I would like to train myself about using this one. So, today, I got my little Home Labs servers and I'm trying to install Tiki Wiki by myself but, it doesn't seem so simple. Maybe it's my Home Lab that is not so simple.

Here is my issue:
- I got an ESXi 7.0U2 with 16 Cores and 64 GB of RAM
- I installed some VMs, and 2 specific VMs for Wikis, CMS, Flarum, etc. I want to try both of these 'tools' to try to find the one I will use everyday, in order to keep all the tutos and other specific solutions and settings that I found all over the Internet. I got a lot of things, codes, etc. i want to keep on my personal NotePad. I know, there's OneNote or Notepad++. But I want to test different solutions. And I will learn about these!
- One of the VMs is a Debian 11, with only MariaDB on it. MariaDB is used for AzerothCore/TrinityCore, Flarum, WordPress, Wikis
- The other one is on Debian 11, with nGinX, and all the dependancies like PHP (7.4), Git, Zip, Unzip, etc. No MariaDB. What for? the SQL Debian Server is installed with it!

So today, I'm looping between the 'Security Precautions' screen and the Install First Screen. Again and again. I tried to installed TikiWiki manually but it doesn't seem that the DataBase is fully populated. So, the Wiki is not working correctly. Some hyperlinks are not responding. And I try to do an 'hybrid' install, like populate manually the DB and try to reinstall Tiki Wiki with the install.php. Tiki Wiki tried to populate the DB again and, hooray!, I was on the Dashboard. But the site were not fully working as I said just before.

So, I would like to know why Tiki Wiki is not fully installed and why some other Wiki (ie. wikimedia, sorry) installed correctly, without any errors, and without any changes on my Debian 11 nGinX. Is Tiki Wiki (or me?) missing something?

If someone here can help me, I would be very happy to understanding what is not working (or what I am missing, maybe :-))!

Thanks a lot


Mmm... Tiki version ?
Did you check : https://doc.tiki.org/Requirements

PHP version HTML or CLI ...?

Sorry only questions and no solutions yet. ;-)