Loading...
 
Features / Usability

Features / Usability


Newsletter welcome mails untranslated

posts: 41 Germany

Hi,

I have the problem that the "welcome to our nesletter" mails are not translated by the system. I have checked there exists a translation for this email template and all the other mails which are going out (for example "the click the following link to accept the subscription to the newsletter-mail") is also translated fine in german.

I have checked the templates and every sentence is covered correctly with {tr}{/tr} tags...rolleyes

Maybe somebody has an solution why the translator does not translate the mail templatequestion

Big, big thanks...

Pete

posts: 1092

First which tiki release? A lot of things change between 1.8 and 1.9
Second is it a multilingual site or monolingual : can user change their language?

I tried on 1.9 cvsin French it is ok for me ... so it is not so simple

1) did you clear the cache admin/admin system / clear templates_c
2) is the email used to subscribe is an email from somebody already registered?If yes, what is this user language? de?

The conceptual model for the newletter is not the best yet. I hope it will change in 1.10. The subscription is based on email and not user. it needs to be on both: user has his own linguistic prefs, anonymous has the site pref.
And I think that a newsletter must have a language field.... I don't image bilingual newsletter, do you ?

posts: 41 Germany

Hi,

I am using 1.9rc1, base language is set to "de", multilingual is turned on and database is used for translation and the user can change the language.

I plan to have multilingual newsletter in the feature, this is also the reason why I don't want to enter directly german text into the mail template.

I am not shure, maybe the system does not recordnise that the "activate newsletter link" is from a user which has set the language to german?

Maybe you got an idear?

Big, big thanks. biggrin

Pete

posts: 1092

How did you set up the translation into the database? Perhaps the string is missing? Can you check if it is in you db?
I don't work with the translation into the database
Can you try to swithc back to translations not in database but in language.php because this file has the translation of "Welcome to our newsletter!"

posts: 41 Germany

Everything is translated in the database, seems that the translator sometimes not recordnise the {tr} tag question

I try to set back to language.php


posts: 41 Germany

Big thanks!

It works now, perfect, seems to be a little bug when translate via database.neutral

posts: 1092

THe problem with "trnaslation is database" is that ... I think ... you don't have a tiki tool to upload the language.php to the database, I am right? So depends of the way people do it.
Some people compare the speed between database and language.php. Seems to be very close.
I never use translation in the db.
You can speed up your de site by compiling the templates for de in the panel admin/ system admin.
Some optimizations are still be done for the tra functions... I hope to have time to do it for 1.10

posts: 41 Germany

I made the translations directly from the admin/edit languages entry, which is very compfortable. The language file for de, was still in the db after install tiki-wiki 1.9rc1 (?).

But, I think, I will use now only the language file... it makes not so much problems like the db translation.mrgreen


posts: 1092

THe problem with "trnaslation is database" is that ... I think ... you don't have a tiki tool to upload the language.php to the database, I am right? So depends of the way people do it.
Some people compare the speed between database and language.php. Seems to be very close.
I never use translation in the db.
You can speed up your de site by compiling the templates for de in the panel admin/ system admin.
Some optimizations are still be done for the tra functions... I hope to have time to do it for 1.10

posts: 41 Germany

I made the translations directly from the admin/edit languages entry, which is very compfortable. The language file for de, was still in the db after install tiki-wiki 1.9rc1 (?).

But, I think, I will use now only the language file... it makes not so much problems like the db translation.mrgreen


Upcoming Events

No records to display

Menu