Loading...
 
Architecture / Installation

Architecture / Installation


Where is tiki-1.9-mysqli.sql?

posts: 5

MySQL 4.1, UTF charset, PHP5.

When I choose "MySQL (mysqli driver)" while installing TW and try to install with default installation profile, the output is

Image
Warning: fopen(db/tiki-1.9-mysqli.sql) [function.fopen]: failed to open stream: No such file or directory in /data/www/2104/slovaktw/tiki-install.php on line 41 Fatal: Cannot open db/tiki-1.9-mysqli.sql

because, of course, tiki-1.9-mysqli.sql doesn't exist. And of course, standard MySQL driver doesn't work, because MySQL4.1 has limit of 333 chars (1000B = 333 chars in UTF). Please help.

posts: 1092

Perhaps a completly stupid answer ...
Did you try to copy db/tiki-1.9-mysql.sql to db/tiki-1.9-mysqli.sql. the sql syntax can be closed enough...
sylvie


posts: 5

thanks, I've tried that. Doesn't work - if you use UTF charset as your db default.

I think it's time to try again my old script - but I don't guarantee it works, I've created it back when MySQL4.1 wasn't officially supported. It makes some columns shorter - so stability depends on what kind of data will be in
tiki_newsreader_marks
tiki_page_footnotes
tiki_searchindex
tiki_secdb
tiki_user_assigned_modules
tiki_user_taken_quizzes
tiki_user_votings tiki_user_watches
which are affected. The link to the script is here: http://tikiwiki.org/tiki-view_forum_thread.php?comments_parentId=15607&forumId=3