Architecture / Installation

Architecture / Installation

Header already sent / XML cannot be displayed When user logs in

posts: 26

php 5

Home Page is working fine.

As soon as I login with an user that is admin (dunno about simple registered user), right after login I get this on tiki-index.php:

The XML page cannot be displayed
Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.


Only one top level element is allowed in an XML document. Error processing resource 'http://www.xxxxxxx.com/tiki...

<b>Notice</b>: Undefined offset: 0 in <b>.../lib/tikilib.php</b> on line <...

If I try to go to the root domain, (www.xxxxx.com) (Tiki still recognizes me as logged in, I then get this:

Notice: Undefined offset: 0 in /home/user/public_html/lib/tikilib.php on line 5525
header already sent

I looked around, turned off Gzip, cache is all clear......... I really don't know what to do.
My Tiki works only if no user is logged on.

It works fine for a while, I was adding articles and stuff, then one day I logged in and I got these errors. Nothing changed and something screwed up.

What do I do? I have a bunch of content and I just want to fix it. I have spent 2 hours online trying to look up solutions and nothing seems to match my problem exactly.

Thanks for any help!

posts: 1585 Canada
Try using Firefox. You should be able to see the rest of the page.
posts: 26

How is the problem fixed then? I don't use FireFox, it has bad HTML rendering and it does not work the way I work with SlimBrowser.
I have other people loggin in with Explorer as well. This needs to work for them.

posts: 26

When using FireFox, I still get the following error when login in with a user:

Notice: Undefined offset: 0 in /home/cpadmin/public_html/lib/tikilib.php on line 5525

But I see the rest of the page.

How do I fix this so that it works for all browsers?

posts: 47 France

Looks like it is a little "bug"

Actually , you are using a rss id which does not exist as
in a wiki page or somewhere.

Check the rss you use actually exist.

Anyway, tw should verify it's an existing feed, the correction in lib/tikilib.php before line before 5524 would be to add:

$items = $rsslib->parse_rss_data($rssdata, $id);

// add that line
 if (!$items) continue;


I hope that will help

posts: 26

Damned straight! I am using an RSS feed that busted it's bandwidth today, so it was not available anymore.

That is indeed what changed in my situation.

I added the if (!$items) continue; on line 5523 and it works now.

Very astute. Thank you so much!

Someone will correct this I hope in the next builds? How do we make sure of this?

Upcoming Events

No records to display