Loading...
 
Features / Usability

Features / Usability


Tracker input fields missing from registration

posts: 7

I'm implementing a registration tracker to collect data from new users of our wiki. When I add the tracker to a wiki page, the input fields are included in the HTML correctly and I can add tracker data. But when I add the tracker to my group for registration, the input fields are not being included in then HTML and I cannot add tracker data. The field labels and descriptions are included; just no input control.

My tracker includes a user-selection field, and I have specified that field with the User Information Tracker. I have added the input fields to the Users Information Tracker Fields Asked at Registration Time field.

I checked the forums and the documentation and didn't see an example of a problem similar to this one. Is this a bug in Tikiwik, or have I missed a configuration somwhere.

I'm on Tiki 3.5.

Thanks.

Win

posts: 1092
Check if an anonymous can create an item for this tracker.

posts: 7

Sylvie,

Thanks for the suggestion. When I look at the tracker wiki page, the input fields are not missing. I added the permissions tiki_p_create_tracker_items and tiki_p_modify_tracker_items to Anonymous, and added the Tracker to the Anonymous group. The input fields are still missing. I must have overlooked something, but I haven't figured out what yet.

Win


posts: 7

I corrected my initial reply, but here is some more information. If I view the tracker wiki page while logged in, I see the input fields. If I view the tracker wiki page while not logged in, I do not see the input fields. Anonymous, by definition, is not logged in. I have rechecked that the tiki_p_create_tracker_items and the tiki_p_modify_tracker_items permissions have been granted to the Anonymous group.

At this point, the availability of the fields seems to be dependent on being logged in. Which creates something of a catch-22: you can't enter the data until you can log in; you can't complete the registration until you complete the data.

I'd welcome other suggestions or insight at this point.


posts: 16 US

I know this is a terribly late reply, but I was having the same problem and wanted to report what I had to do.

For my site registration, I wanted to require users to enter their reason for joining, because I suspected that despite the captcha information, that there were some bogus attempts to join the site.

I followed the instructions for setting this up to the tee to add a text field to the tracker, but all that would appear was the title of the field and its description — no input field.

I had selected the "Multilingual" checkbox as an option for the field. When I deselected it, the input field appeared. I haven't dug super deep into the multilingual options yet (not until I get done translating the language file into Esperanto), so I'm not sure why that would be an issue. But for what it's worth, deselecting that as an option fixed the problem (I'm using tiki 12.2).

— Kat


Upcoming Events

No records to display

Menu