Architecture / Installation

Architecture / Installation

Unexpected character in setup.sh

posts: 4 USA

I'm trying to install tiki-11.0 on Hostgator.
When I run setup.sh through putty I receive an error:__

studentp at studentpla.net ~/public_html/wiki# bash setup.sh

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in - on line 395

  1. !/usr/bin/env php

Some settings on your machine make Composer unable to work properly.
Make sure that you fix the issues listed below and run this script again:

The phar extension is missing.
Install it or recompile php without --disable-phar

Your PHP (5.2.17) is too old, you must upgrade to PHP 5.3.2 or higher.

We have failed to obtain the composer executable.
NB: Maybe you are behing a proxy, just export https_proxy variable and relaunch setup.sh
1) Download it from http://getcomposer.org
2) Store it in temp/

I asked Hostgator to help and their answer below:
I was able to run the script by manually downloading composer for it. There is a fatal error when running the script but it continues to run past the error. I do not know if this error will hinder what the script is attempting to do since I quit the program before doing anything.

studentp at studentpla.net ~/public_html/wiki# ./setup.sh

Fatal error: Class 'Phar' not found in /home2/studentp/public_html/wiki/temp/composer.phar on line 13

Fatal error: Class 'Phar' not found in /home2/studentp/public_html/wiki/temp/composer.phar on line 13

Tiki setup.sh - your options

f fix (classic default) o open (classic option)

predefined Tiki Permission Check models:

1 paranoia 2 paranoia-suphp
3 sbox 4 mixed
5 worry 6 moreworry
7 pain 8 morepain
9 risky a insane

q quit x exit

There are some other commands recommended for advanced users only.
More documentation about this: http://doc.tiki.org/Permission+Check
Your choice f? q
Could you please help?__

posts: 4 USA

Thank you Tom.
Actually the PHP Version is 5.3.27. I do not know why it considered it as 5.2.17.
Anyway, I succeeded to run the script. It fixed automatically a few problems and it seems that Tiki is OK now.

posts: 1585 Canada

Perhaps the command line version of PHP is different?


php -v

posts: 4 USA

I quite new to all this. I asked HostGator support to help. They did something but I don't know exactly what they did. you can read their answer above.
I run again putty and attached the log for your consideration.
Thank you very much for your help.

posts: 1585 Canada

OK, they must have upgraded your PHP version on the command line.

Composer seems to want to run but you don't need it because you got Tiki from a .zip which contains everything.

If you ignore that error and proceed, does the site work?

posts: 4 USA

Thank you Marc

In my previous response I attached a new PUTTY session with no complaints about PHP version or Composer.

Right now, it seems that Tiki is running quite well.
Please visit http://studentpla.net/wiki/

posts: 1585 Canada

Ok, good. I hope you like it and it helps you with your project

Best regards,

M ;-)

Upcoming Events

No records to display