Loading...
 
Features / Usability

Features / Usability


Plugin LIST (with tracker) only works for admins

posts: 42 Spain

Sorry again for my mistake writing the message in this forum

Hello,
I would like to ask for help with this problem...

I have a wiki page with the LIST plugin, that shows data from a tracker, which are links to wiki pages. That works ok with adminr permissions, but when a user without administrator permission, the page opens, but can not find any data, this is the message that appears: "no search results"

Why the LIST plugin only find results when the query is done by an administrator??


Thi's the code in the wiki page

{LIST()} {pagination max="1000"} {filter field="tracker_id" content="8"} {filter type="trackeritem"} {sort mode="tracker_field_cbdActivitat_asc"} {OUTPUT(template="table")} {column field="ref_1" label="Activitat" mode="raw"} {column field="ref_2" label="Descripció" mode="raw"} {column field="ref_3" label="Pàgina" mode="raw"} {tablesorter server="n" sortable="type:reset" tsortcolumns="type:text|type:text|type:text" tsfilters="type:text;placeholder:Escriu aquí per cercar...|type:text;placeholder:Escriu aquí per cercar...|type:text;placeholder:Escriu aquí per filtrar..." tspaginate="max:25"} {OUTPUT} {FORMAT(name="ref_1")}{display name="tracker_field_cbdActivitat"}{FORMAT} {FORMAT(name="ref_2")}{display name="tracker_field_cbdDescripcio" default="sense descripció"}{FORMAT} {FORMAT(name="ref_3")}{display name="tracker_field_cbdPagina" format="objectlink" format="trackerrender" default="no disponible"}{FORMAT} {LIST} 


Thank you very much and greetings

Santi


posts: 2428 Czech Republic

Hi,
make sure your tracker data is accessible by groups other than Admins.

luci


posts: 42 Spain

Thanks you all for you help.
But... nothing has worked for me.

I have verified that the problem is that only with the "tiki_p_admin" permission can the LIST plugin be used.
Users without administrator permission can access the trackers and all others functions, but not run a page with the LIST plugin.

This only happens with the online tiki.
With the test tiki that I have installed in local (with wamp), everything works fine.

So I think it's a problem of permissions, but I've already tried to give all the permissions to a group, except the "tiki_p_admin" and that's when the LIST plugin does not work. Uffffffffffffffffffffff

Now I'm working with 18.0 and I'm thinking on updating to 18.1, to see if this is fixed.

Any other sugestion?

Thank you very much and best regards

Santi


posts: 8511 Israel

Mmm...

This is working for sure in Tiki 18.1 (and I’m pretty sure it was also working on Tiki 18.0).

I recreate from scratch on a demo reproduced your case (admin can see, user can’t see).
As you can see I got after, setting permissions for register (tiki_p_view_trackers) and THEN rebuilding index (tiki-admin.php?page=search).

1 Aftercreation
2 Usercantsee
3 Afterindexrebuild

You should recheck...


posts: 42 Spain

Hi Bernard,
I have done it, again, and now it works ok.

Thank you very much for your great help.

thanks and best regards

Santi