Loading...
 
Architecture / Installation

Architecture / Installation


Admin Login on New Install

posts: 119 United States

Hey everyone,

I've got a new install of 21.5. Everything works well through the install, but as soon as I start to navigate as the admin, I get an error message that I don't have the permission tiki_p_admin. I've checked in the database to make sure something isn't off, but the admin group does have that permission. I've tried deleting that line and manually adding back to the table, but I still have the same problem. At best I can sign in and navigate to a few pages, but then I get kicked out.

Any thoughts on what is causing this issue? I'm not even sure where to look. I thought maybe something was bad on the install, so I uploaded the files to another directory and created a new database, but it's still the same issue.

The only thing I can figure is something with my hosting, but I'm not sure what to check.

Thanks,
Greg

posts: 119 United States

I went through the action log and found that each time I get kicked out, there's a message that says system cookie validation failed.

I've been reading through the session and cookie documentation that I can find, but haven't been able to fix this.

The sessions are stored in /tmp, and there is write access to this folder. When I go in the folder there are a few files that were all created right about 30 minutes after I did the install. There is a .lock file, and I'm not sure if that's causing the issue or is normal.

Any thoughts on what I need to do? I've installed Tiki many times, and have never run into this issue.

Thanks,
Greg